Ich musste gerade zu meinem Entsetzen bemerken, dass der standardmässige Mail-Client von Android 2.3 (wie es mit späteren Versionen steht, weiss ich nicht) da ein paar sehr schlechte Angewohnheiten hat, die unter (unter Umständen schwer zu bestimmenden) gewissen Bedingungen dazu führen, dass Mail von Smartphones nicht angenommen wird.

Das betrifft aber nur Nutzer, die hier (mail.ax11.de) einen Account haben und Mail hinausschicken wollen. Hypothetische Mail von fremder Leute Smartphones, die angeblich „nicht angekommen ist“, hat nichts mit uns zu tun.

Unschönerweise lässt sich der Android-Mailclient nämlich auf einen HELO-ELHO-Dialog ein (der eigentlich anderen Mailservern, nicht –clients vorbehalten ist) anstatt sich einfach per User/Passwort zu authorisieren, auch wenn man das so eingestellt hat.

Normalerweise geht das sogar noch gut. Ausser, das Androidchen ist per WLAN verbunden. Dann benutzt es nämlich die lokale IP4-Adresse, die es innerhalb des WLANs zugewiesen bekommen hat, wovon der Mailserver erwartungsgemäss gar nichts hören wollte und die Annahme verweigerte. (Korrekt wäre die öffentliche Adresse des WLANs, bzw. dessen Routers, internen Adressen dürfen nach RFC1918 niemals nach aussen geroutet werden).

Ich habe das als vorrübergehenden Fix jetzt mal entschärft. Falls also jemand Smartphone-Mailserver-Probleme der dritten Art hatte, oder von mir unvrschämterweise tagelang keine Antwort bekommen hat (leider pfeift der Android-Mailer auch nichts davon, sondern hamstert ausgehende Mail heimlich in der Outbox) – jetzt sollte das gehen.

Ich kann aber nicht garantieren, das auf ewig aufrecht zu erhalten, weil sich das SPAM-Aufkommen dadurch definitiv erhöhen dürfte. Weiss evtl. jemand einen besseren Mailclient (IMAP-SSL/SMTP) für Android 2.3.3? Mit ähnlich guter Integration? Wäre IMHO angebracht, das Übel an der Wurzel zu packen, anstatt am korrekt konfigurierten Server herumzudocktern.

 

Android 2.3.3. Mailer-Probleme…

2 Gedanken zu „Android 2.3.3. Mailer-Probleme…

  • 22. August 2012 um 10:30
    Permalink

    Dere!
    hab mal auf einem HTC Tatoo<?, dessen Datum/Uhrzeit auf 1980 eingestellt war, versucht den Android/Market… Gmail Account zu aktivieren. Ging ned, Fehlermeldung: Certificates Error ….. bis ich drauf kam dass das Datum falsch eingestellt war ..grrr.. danach liefs…. worauf ich hinaus will: ich habe mit Thunderbird mal beepbot automatisch konfigurieren lassen, der spuckte auch immerwieder ein Certificate Error asa….
    Gruesse,
    bob

    Antworten
    • 22. August 2012 um 18:25
      Permalink

      Nee, das ist es in diesem Fall nicht. Certs sind OK, weil ich die CACERT unter die akzeptierten CAs importiert habe. Das Problem ist die eigenwillige Art, wie Android mit HELO umgeht.

      Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.